Activity Forums Questions & Troubleshooting Hardware Trouble connecting SIM800L to controllino MAXI

  • Trouble connecting SIM800L to controllino MAXI

     Lukas updated 1 week, 1 day ago 3 Members · 4 Posts
  • w-mets

    Member
    January 23, 2021 at 6:53 am

    Hi Guys,

    I’m trying to get some data on the internet with a SIM800L shield and a SIM-card. On a controllino MINI I finally got the SIM running with stable connection. I’m using the interrupt pins for TX and RX (2, 3), and for now it seems to work just fine.

    I tried this exact setup on two diferent MAXI’s over and over again (interrupt pins 18, 19), but it just won’t work! Any suggestions?

    • This discussion was modified 1 month, 1 week ago by  w-mets.
  • mr-controllino

    Administrator
    January 25, 2021 at 7:56 am

    Hi,

    1) What kind of SIM800L are you using? There are some with carrier boards and some plane boards.

    2) What is the power supply for the SIM800L? It needs special voltage and a lot of current!

    3) It is always better to use pins that have unique communication functions. Like the UART2 on the X2. Pins that are used as inputs are additionally protected by 1k serial resistors.

    regards
    Marco

    • w-mets

      Member
      January 25, 2021 at 11:07 am

      Hi Marco,

      Thanks for your reply!

      1) I have two SIM800L’s available for testing, the small red 800L core board and the RoHS SIM800L EVB 2.0. I guess they are both plane boards.

      2) I tried different power supplies. I tried some battery stacks and a Meanwell HDR-15-5, 2.4 amps with a 100N capacitor. Both SIM-modules mentioned above are running steady now on the MINI.

      3) Which pins on the X2 do you exactly mean for UART communication? I tried pin 16 (TXD2) and 17 (RXD2) and pin 18 and 19 on the MAXI, neither of them were succesfull.

      Thanks agian!

      Best regards,

      W. Mets

      • Lukas

        Member
        February 23, 2021 at 10:25 am

        Hi W. Mets,

        I am wondering how you have used the pins 2 and 3 for the UART at MINI? Are you using SoftwareSerial library? I assume that you connected the shield to the X1 pinheader, right?

        Next point is the MAXI – here you should use pins 18 and 19, but the communication must be done through Serial1 .

        Thanks,

        Lukas

Log in to reply.

Original Post
0 of 0 posts June 2018
Now