Activity Forums Questions & Troubleshooting Hardware Analog input always reads 0 :-(

  • Analog input always reads 0 :-(

     Jarda updated 1 year ago 2 Members · 3 Posts
  • bruno

    Member
    August 19, 2020 at 1:27 pm

    I just bought a MAXI from CONRAD. It’s connected to 12 Volt. I ran some examples. Uploading programs work well, also serial terminal etc.

    I experienced some troubles though:

    • Running the blinking example, the LED are blinking, but the outputs on the according screw terminal do not show any signal (Should be12 V, right?).
      • Running the analog read example, the script always reads zero 0. I connected the A0 to the 12V of the supply, but still 0V. Then I tried to feed the 5V on the same screw terminal strip where the A0 is located, still 0V. Then I measured the voltages. The 5V header has no 5V and the ground has no connection to the ground of the device (Supply ground). Is it possible that all the upper screw terminal are disconnected from the board? I haven’t opened the MAXI because of warranty etc. Strange is, that the LEDs seem to work

    The relays work though…

    Thanks for your help

    Bruno

  • bruno

    Member
    August 26, 2020 at 10:47 am

    I got a new device from CONRAD which works…

  • Jarda

    Member
    September 20, 2020 at 6:13 am

    Hello,

    we are sorry for complication, looks as the production fail.

    Enjoy the new CONTROLLINO.

    Regards

    Jarda

Viewing 1 - 3 of 3 replies

Log in to reply.

Original Post
0 of 0 posts June 2018
Now